Detta inlägg är lite av vad syftet av min webblogg var från början, ett anteckningsblock över nyttiga saker som jag råkat ut för och som jag på något sätt behöver bevara. Hittills har jag nästa bara skrivit saker som är Linuxrelaterat men nu kommer en liten logg om Windows, ATI och Philips FullHD-TV.

Jag har sällan skådat en sämre kombination, funktionalitet och konfigurering för att få något så enkelt som att använda en TV med HDMI som monitor som denna.

Min hårdvara i vardagsrummet bygger på en dator med ett ASUS M4A785TD-M EVO-moderkort som har ett integrerat ATI HD 4200 grafikkort, AMD Phenom IIX3 720 2.8GHz processor och 4Gb minne som körs på Windows 7 Ultimate 64-bitar som är kopplad till en Philips 42″ FullHD-TV (42PFL8654H/12) via HDMI.

Det hela började med att musen laggade rejält, jag har även märkt att min PS3 laggar gällande bild. Det verkar hela tiden som att allt som ansluts via HDMI till min TV släpar efter nästan 500ms vilket är löjligt mycket gällande läpp-sync och muspekaren.

Lösningen på detta är att jag måste gå in och ställa om TV i dess inställningar under Bild och i princip stänga av alla fina funktioner för bildmanipulering för att göra bilden finare, snabbare, bättre. Det fanns ett snabbt sätt att göra detta genom att välja “Datorläge” = “Till”.

Ett annat problem är att bilden fyller inte ut hela skärmen när man väljer 1080p-upplösing (1920×1080). Bilden är suddig och oskarp, precis som att grafikkortet sänder ut fel upplösning eller att bilden är skalad på något sätt. Efter mycket testade hittade jag att bilden faktiskt var nedskalad som default med 15% och så fort jag satte det på 0% blev bilden knivskarp samt fyllde ut hela ytan. Detta gjorde man via Catalyst Control Center (ccc) under Desktops and Displays. Där finns en flik som heter Scaling Options och den var ställd till 15% “underscan” som standard vilket är märkligt.

Nästa problem vilket tydligen är relativt vanligt med ATI och Philips TV-apparater är att bilden blinkar till och blir blå/grön under ett par minuter. Detta händer ett par minuter till 30 minuter från att datorn startat och upprepas slumpmässigt. Det visade sig att standardläget som ATI-drivrutinen använder inte är optimal för Philips och måste ändras gällade pixel-formatet som skall ändras från YCbCr 4:4:4 till RGB 4:4:4. Detta hitta man också i ccc på samma ställe som scaling options fast under fliken “Pixel format”.

Ett stort fång ris till Philips som inte skriver något om detta i sin FAQ då nätet vimlar av liknande fall och ett till ATI som kanske borde samarbeta med Philips för att lösa detta problem en gång för alla.

— Johan Ryberg

9 thoughts on “Philips TV och ATI HD 4200, en krånlig historia

  1. Intressant det där med att Philips TV blinkar till och blir blå/grön. Jag har nämligen samma problem. Har också en Philips-TV och ATI grafikkort.
    Men jag hittar inte det som ska ändras i CCC som du förklarar. Vore jättesnällt med en mer detaljerad förklaring!
    robert_aberg87(a)hotmail.com

  2. Hade först svårt att hitta rätt med men om man går in på deskop & Displays och så högerklickar man nere på den lilla skärmen och väljer configure och scaling options så drar man bara den till 0. har också en Philips 37" som jag har ballat med länge men nu äntligen funkar det som det ska.

  3. Hej

    Tusentack, men säger samma sak som Robert, hittar heller inget där jag kan byta till RGB

    Har CCC 2010.0706.21.25.36662

    Mvh
    Jonas

    Svara gärna i bloggen, eller kommentarer så läser jag där 🙂

  4. Svar på ovan frågor gällande vart man hittar RGB-inställningen.

    Denna hittas som sagt under Catalyst Control Center under menyn Desktops & Displays.

    Högerklicka på önskad monitor och välj Configure.

    Då kommer ett antal flikar upp varav man skall välja den som heter "Pixel Format" och där kan man välja t.ex. RGB 4:4:4

    // rancor

  5. Jag har bara "Attributes", "Adjustments" och "Color" när jag väljer "configure" på önskad monitor. Är det senaste versionen av ccc som ser annorlunda ut?

  6. Jag har haft samma problem ett tag och hittade samma lösning som du. dock har jag fortfarande själva blinkandet kvar (blinkar svart). Det blir jag inte av med 🙁
    Känner du igen att detta?

  7. Jag hade också samma problem men löste dem tack vare vad ni har skrivit här. Har en Philips 37" och ATI HD 5470.
    Problemet är nu bara att bilden blev sämre och det går inte längre se på filmer i BlueRaykvalitet längre (det fungerade klockrent innan och var grym kvalitet tills dess att allt då blev grönt) Antar att RGB 4:4:4 är sämre och inte klarar av samma upplösning. Går det lösa det här på något sätt?

Leave a Reply

Your email address will not be published. Required fields are marked *